Dashboard won't start

For the early roll-out of the Dashboard

Moderator: pa3weg

Dashboard won't start

Postby gm8oti » Sat Nov 16, 2013 8:08 pm

Having problems even getting the program to run - get the Microsoft diagnostics box suggesting error report to Microsoft.

Have Windows XP Professional SP3. Had to install Net Framework 4 as noted elsewhere to get install to run.

There are 5 files in the Dashboard folder:

Audiolib.dll
Dashboard.exe
Dashboard.exe.config
libfftw3f-3.dll
portaudio.dll

Microsoft error gives:

FUNcube-1 Dashboard has encountered a problem and needs to close. We are sorry for the inconvenience.

The error report contains stuff I can't cut and paste :-) but has Event type : clr20r3 P1: dashboard.exe <other stuff>
P9: system.io.fileformatexception

I can copy the error report contents to you if you wish.

Ummm - wonder what's missing? Sorry can't be more helpful, I usually use Linux but have this Win XP machine for stuff when I need it, like this Funcube stuff.

John
GM8OTI
gm8oti
 
Posts: 14
Joined: Thu Nov 14, 2013 3:26 pm

Re: Dashboard won't start

Postby g4dpz » Sun Nov 17, 2013 11:25 am

Are you using version 800 or an earlier one. I just tried it om my XP Pro SP3 and it worked fine.

73

- Dave
g4dpz
 
Posts: 143
Joined: Sun Oct 06, 2013 9:07 pm

Re: Dashboard won't start

Postby Duncan » Sun Nov 17, 2013 11:29 am

Sorry to hear you are having trouble, please post the contents of the error report, it might give us something to go on...

The files you have are all that's needed, none of the files need registering, just being in the folder with the .exe is enough so there is not a lot to suggest there. If you haven't already tried, re-running the installer and selecting repair may help.

As we make heavy use of sound devices, it may also be worth checking that their drivers are up to date, if there are any usb sound devices try starting with them removed.

Other than that, is there anything unsusual about your setup? Strange processor, running in a VM, user with limited permission etc...

Cheers,
Duncan.
Duncan
 
Posts: 58
Joined: Tue Oct 08, 2013 5:56 am

Re: Dashboard won't start

Postby gm8oti » Sun Nov 17, 2013 11:45 am

Now version 800. Had tried 798 and got the same error.

A bit at a loss since you have it working on XP Pro. The Net Framework stuff is new, maybe I need to find a way to test that.

The error header is:

Error signature:

EventType : clr20r3 P1 : dashboard.exe P2 : 1.0.800.1 P3 : 52856ff0
P4 : presentationcore P5 : 4.0.0.0 P6 : 4ba1f865 P7 : 44dd
P8 : 47 P9 : system.io.fileformatexception

Unfortunately the detailed module list and hex dump can't be selected for copy and paste. I could screenshot some of it I suppose, but there's a lot. Do you know how to get a copy of it?

Cheers
John GM8OTI
gm8oti
 
Posts: 14
Joined: Thu Nov 14, 2013 3:26 pm

Re: Dashboard won't start

Postby Duncan » Sun Nov 17, 2013 11:57 am

Hi john,

I'm currently out and about at the moment, I will send you a pre-release of the next version when I get back, this includes better exception handling and will make pinpointing the issue much easier...

Cheers,
Duncan.
Duncan
 
Posts: 58
Joined: Tue Oct 08, 2013 5:56 am

Re: Dashboard won't start

Postby gm8oti » Sun Nov 17, 2013 12:02 pm

Thanks Duncan, no worries, no rush!

I'm currently trying to get MS update to work .....

John GM8OTI
gm8oti
 
Posts: 14
Joined: Thu Nov 14, 2013 3:26 pm

Re: Dashboard won't start

Postby Duncan » Sun Nov 17, 2013 12:07 pm

Oh but there is a rush... We fly* on Thursday!!!

*well, fall but miss the earth, hopefully!
Duncan
 
Posts: 58
Joined: Tue Oct 08, 2013 5:56 am

Re: Dashboard won't start

Postby gm8oti » Sun Nov 17, 2013 1:10 pm

Yes so all the more reason not to waste your time if it's a problem with my silly MS setup.

I'm reinstalling SP3 at present - the Background Intelligent Transfer Service was missing, which was preventing MS update from working ...

John
gm8oti
 
Posts: 14
Joined: Thu Nov 14, 2013 3:26 pm

Re: Dashboard won't start

Postby gm8oti » Sun Nov 17, 2013 3:54 pm

Thanks Duncan, received your email with pre-release 801.

I was in the middle of a SP3 reinstall so let that complete. After that, 800 still doesn't start. (But then I can try windows update again for drivers now ...)

Hoiked across 801 anyway, to try that. The debug works ;-)

Here you are:

---------------------------
FUNcube-1 Dashboard Error
---------------------------
Sorry, an error has occured please seek help at forum.funcube.org.uk copying (CTRL+C) the following information

System.IO.FileFormatException: The image format is unrecognized. ---> System.Runtime.InteropServices.COMException: Exception from HRESULT: 0x88982F07
--- End of inner exception stack trace ---
at System.Windows.Media.Imaging.BitmapFrameDecode.EnsureThumbnail()
at System.Windows.Media.Imaging.BitmapFrameDecode.get_Thumbnail()
at MS.Internal.AppModel.IconHelper.GetBestMatch(ReadOnlyCollection`1 frames, Size size)
at MS.Internal.AppModel.IconHelper.CreateIconHandleFromImageSource(ImageSource image, Size size)
at MS.Internal.AppModel.IconHelper.GetIconHandlesFromImageSource(ImageSource image, IconHandle& largeIconHandle, IconHandle& smallIconHandle)
at System.Windows.Window.UpdateIcon()
at System.Windows.Window.SetupInitialState(Double requestedTop, Double requestedLeft, Double requestedWidth, Double requestedHeight)
at System.Windows.Window.CreateSourceWindow(Boolean duringShow)
at System.Windows.Window.CreateSourceWindowDuringShow()
at System.Windows.Window.SafeCreateWindowDuringShow()
at System.Windows.Window.ShowHelper(Object booleanBox)
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
at MS.Internal.Threading.ExceptionFilterHelper.TryCatchWhen(Object source, Delegate method, Object args, Int32 numArgs, Delegate catchHandler)
---------------------------
OK
---------------------------

Cheers
John
gm8oti
 
Posts: 14
Joined: Thu Nov 14, 2013 3:26 pm

Re: Dashboard won't start

Postby Duncan » Sun Nov 17, 2013 5:52 pm

Thanks for that (I think!) a really odd one, a COM exception in an app that doesn't overtly use COM!

I think the clue is in all the references to icons and images, I will investigate there first...

Good to know the exception handling works though!

Cheers,
Duncan.
Duncan
 
Posts: 58
Joined: Tue Oct 08, 2013 5:56 am

Next

Return to Dashboard Software questions, problems and bug reports

Who is online

Users browsing this forum: No registered users and 2 guests

cron